The Profile Brotherhood RC Forum banner
1 - 12 of 12 Posts

·
Registered
Joined
·
445 Posts
Discussion Starter · #1 ·
Just a question for those of you who are more experienced with computer radios and such than i am :D I have JR 652.. say i have my low rates trimmed in perfect....when i go to high rates the elevator goes down and it takes about 12 clicks of up to correct it. I messed around with my radio for a bit and figured out that if you have no expo on low rates it takes about 80% on high rates to make them equal so there is no difference in trim, I definitely don't want 80% expo...im shootin for 0% high and low rates. Is there a way to fix this so i don't need any expo? I know that i could just set up high rates but then I don't have any back-up not so wild throws.

Any help is appreciated so that I can do my hovering and practice TR'in closer in :twisted: its no fun being close to the ground on low rates and then go to high rates to pop up into a wall and hover cause when you go from low to high it sorta shoots down toward the ground :shock:
 

·
Registered
Joined
·
445 Posts
Discussion Starter · #3 ·
yeah thats easy for you to say...remember i havn't even been flying for a year yet :wink:
 

·
Registered
Joined
·
3,716 Posts
just dial in more expo on high rates, take your time getting used to flying this way, you will become a better pilot this way.

SCREW LOW RATES!!!!
 

·
Registered
Joined
·
6,472 Posts
I'd check with JR. Your trim shouldn't change between high and low rates. The last radio I had that did that was an old tan case Futaba that I added the dual rates to. If I trimmed the plane by adjusting the clevis' leaving the tx trim centered it wouldn't change from high to low rates. A modern tx shouldn't do that at all.
Later,,,Matt
You might check to see if there are separate trim settings for each rate.
 

·
Registered
Joined
·
278 Posts
I don't know the 652 but I know the 9X has this option for the trims to change when going from low to high or when you have the dual rates setup with the flight modes. Double check the programming on the radio. It might be something really small you're missing.
 

·
Registered
Joined
·
889 Posts
I agree, something in the radio programming is not quite right. Make sure you don't have something programmed in like a landing mode, etc. mixed in there with your rates by mistake, or maybe the switch assignment is causing something else to activate. It's easy to overlook something during programming, especially if it is a new radio.
 

·
Registered
Joined
·
445 Posts
Discussion Starter · #8 ·
i just put a ton of expo on high rates for now....soon i will just use high rates anyways so i wont have to worry about the change in trim.
 

·
Premium Member
Joined
·
796 Posts
it almost sounds like you have another mix, like an elevator offset for flaps or something, programmed to your rates switch... check through your mixes and double check that they are inactive or on other switches.
 

·
Registered
Joined
·
5,491 Posts
You may want to reset that particular memory in your radio back to the factory defaults, that will eliminate any misc. mixes or trims. Then program the model to your liking. If it still does it send it back to horizon.
 

·
Registered
Joined
·
445 Posts
Discussion Starter · #11 ·
i have it pretty good right now and im just going to leave it where it is because its right where id like it to be....i don't think horizon would take it becaues im not the first owner, i bought it from a guy in my club. I had lost all my programs so i had to reprogram it all and it seemed to help because now i have a high rate expo that i like.
 

·
Registered
Joined
·
5,491 Posts
If it works, FLY IT! :D [/b]
 
1 - 12 of 12 Posts
Top