The Profile Brotherhood RC Forum banner

Aerofly pro problems

880 Views 4 Replies 3 Participants Last post by  slyder
Got aerofly a few days ago. Got it all setup and worked great. Thought id have lots of problems with my Futaba t6xa but didnt. So i flew for about 3 hours and then when my transmitter hit 9.6 volts i had no control response. When i went to calibabrate all the controls were fluctuating so i figured it was a low battery.

Check R/C comport it was running ok.

Charged it up and turned it on this morning. Same thing.

The strange thing is when i got into aerofly it would detect the interface cable but when i went to fly it came up with the infamous " Cannot detect interface" message

When i got home from school i got a message from Raptorheli to reinstall so i did and it worked!!

Then when i got to 9.8 volts did the same damn thing.

Then i went out and got a serial port to usb port adapter.

Now it wotn calibrate properly so the control throws arent proper and the engine idle is all wacky. Worse part is when i fly the control surfaces flutter causing crashes alot.

What should i do??? What are my options? I also have a Realflight G2 interface that i could use. Its at my dad's though! Might take a little while to get here. Or could i buy a crappy radio like a 4yf skysport
Anyone have this problem?? Thanks for the help. Tech support is my last resort

Ive already posted this on afp forums and have gotten 3 views in the past 3 days. So im hoping you guys are gonna have more help.
1 - 5 of 5 Posts
Nevermind i think its fixed. IDK how but tis starting to work right.
sounds like what happens to me when that phono jack type plug is partly unpluged, also remove your transmitter crystal modual you will get much more battery life
If you dont know already- be sure to remove your crystal so you do not burn up your TX and your batt. will last a long time.
I use a 6xa with the factory batt. and can fly for many hrs straight.
Well DUH
I skipped right over your post Spastic. Not enough coffee yet. :D
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.